Restoration of all services have been completed and returned to normal.
Posted Jun 04, 2026 - 07:42 BST
Update
The vendor has reported the engineering teams are continuing to work diligently to resolve the ongoing issue affecting the Webex services environment.
We will provide a further update as the services come back to full restoration.
Posted Jun 03, 2026 - 17:18 BST
Identified
This is related to a Cisco issue impacting Webex services hosted in the US region. We are currently observing positive signs of recovery across our Webex service. We will continue to investigate with the vendor to stabilize the service as soon as possible.
Apologies for the incovenience this may cause
Posted Jun 03, 2026 - 16:56 BST
Investigating
We are currently investigating an issue with webex for mobile calls not working. We are investigating with the vendor to resolve this issue as soon as possible. We apologise for any inconvenience this may cause
Posted Jun 03, 2026 - 16:34 BST
This incident affected: Anywhere with Webex (Push Notifications).