Our carrier has advised this is now resolved. If anyone continues to receive reports of failed inbound calls please raise a ticket with our support desk.
Posted Apr 14, 2026 - 17:48 BST
Investigating
Please be advised that we're investigating reports of failed inbound calls. We've traced this to a specific carrier and have escalated with them. We'll provide further updates asap.
Posted Apr 14, 2026 - 17:31 BST
This incident affected: Core Platform (B/W) (Call Processing).