Our upstream carrier have advised they're observing stability, but are still investigating the root cause. Due to this, we'll resolve this incident as we're operationally BAU following the change we made earlier. If you continue to encounter issues, please raise a case with our service desk who will be happy to assist.
Posted Aug 12, 2026 - 15:49 BST
Update
Our primary upstream carrier has published a status page advising they're aware of numerous reports regarding call failures. The changes we've made on our side have introduced stability, but we will continue to monitor the carrier as they investigate the cause.
Posted Aug 12, 2026 - 15:08 BST
Monitoring
We've implemented a fix which is producing favourable results, we're seeing stability return for inbound calling. Please monitor and report any further issues into our service desk.
Posted Aug 12, 2026 - 14:52 BST
Investigating
We are aware of an issue impacting some inbound calls causing failures, we have engaged our engineering department who are reviewing the issue. We'll communicate a further update within 15 minutes.
Posted Aug 12, 2026 - 14:45 BST
This incident affected: Core Platform (B/W) (Call Processing).