Talkdesk have now confirmed the issue is now fully resolved.
Posted Nov 26, 2025 - 09:54 GMT
Monitoring
Mitigation measures have been applied by TalkDesk and they're observing a recovery of sessions. We'll continue to monitor.
Posted Nov 26, 2025 - 09:27 GMT
Investigating
Please be advised that TalkDesk have made us aware of an ongoing issue within their core platform impacting service. As we receive updates on this matter, we'll communicate them here.
Posted Nov 26, 2025 - 08:59 GMT
This incident affected: TalkDesk (TalkDesk - Core).