Secure call Incident

Incident Report for Evolve IP UK

Resolved

This incident has now been resolved.
Thank you for your patience while we investigated and fixed the issue.
Posted Apr 12, 2026 - 13:14 BST

Update

We are continuing to investigate the issue.

We will provide further updates as soon as more information becomes available.
Posted Apr 12, 2026 - 05:16 BST

Update

We are continuing to investigate the issue.

We will provide further updates as soon as more information becomes available.
Posted Apr 11, 2026 - 14:13 BST

Investigating

We are currently investigating an issue where some customers may be unable to secure their calls via the Secure Call.
Initial indicators did not show a broader impact; however, further investigation has confirmed that some customers may be affected. Our team is actively working with a third-party provider to resolve this as quickly as possible.
We will share further updates as more information becomes available.
Posted Apr 11, 2026 - 11:02 BST
This incident affected: Secure Call (Calling).