Voice2Teams Portal Unavailable

Incident Report for Evolve IP UK

Resolved

This has now been resolved
Posted Oct 30, 2025 - 08:08 GMT

Investigating

Please be advised that we're aware of a problem accessing portal.voice2teams.com. This appears to be related to a wider Azure incident. Calls and registrations are not impacted. We'll advise an update as soon as one becomes available.
Posted Oct 29, 2025 - 16:20 GMT
This incident affected: Anywhere with MS Teams (Admin Portal).