Webex Sign-In and Phone Services

Incident Report for Evolve IP UK

Resolved

Cisco have confirmed services are now healthy and stable and are marking the issue as resolved.

We have received no further issues so Evolve IP will now mark this as resolved.
Posted Aug 21, 2026 - 10:46 BST

Monitoring

Cisco has completed the required remediation activities, and services have now been fully restored across all regions.

Please retest your services. If you continue to experience any issues, please raise it with our support team.
Posted Aug 21, 2026 - 09:28 BST

Update

Cisco Engineering has continued its investigation and confirmed that service impacts are ongoing.

For further information, please refer to the vendor’s status page:

https://status.webex.com/commercial/status?lang=en_US
Posted Aug 21, 2026 - 09:14 BST

Investigating

We are investigating an issue affecting Webex users who may be experiencing difficulties signing in to the app or connecting to phone services.

The issue appears to be affecting Webex services globally. We are working closely with Cisco to investigate the cause and restore full service as soon as possible.

We will provide further updates as more information becomes available.
Posted Aug 21, 2026 - 08:55 BST
This incident affected: Anywhere with Webex (Application).