The issue has been identified, and a fix has been implemented. Users can now retry access via the original portal. We will continue to monitor the service to ensure stability
Posted Mar 29, 2026 - 13:56 BST
Update
We are continuing to investigate the issue.
As a workaround, customers will be able to access their account via uk1.dubber.net. This will work for customers who aren't restricted to SSO or XSI-only login.
We will provide further updates as soon as more information becomes available.
Posted Mar 29, 2026 - 13:14 BST
Investigating
We are aware of an issue affecting access to the Dubber portal, with users unable to log in. We have escalated this with the vendor and are investigating as a priority. Further updates will be provided as soon as more information becomes available.
Posted Mar 29, 2026 - 11:31 BST
This incident affected: Anywhere Recording (Dubber) (Portal).