A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 14:45 BST
Update
Cisco continues to investigate the issue; however, we are seeing signs of improvement. We will continue to monitor the situation closely and provide further updates as more information becomes available
Posted Aug 12, 2026 - 11:22 BST
Update
Cisco engineers continue to work towards service restoration.
Posted Aug 12, 2026 - 10:20 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2026 - 09:04 BST
Investigating
Cisco is aware of an issue affecting incoming call notifications on the Webex mobile app, resulting in users not receiving notifications for incoming calls. Cisco’s technical teams are actively working to restore normal service.
We will continue to monitor the situation closely and provide a further update as soon as more information becomes available.